AWS has indicated the issue has now been resolved.
Posted Oct 21, 2025 - 16:56 AEDT
Monitoring
While all our systems are operational, we are actively monitoring our upstream providers for any potential service disruptions related to the ongoing AWS US-EAST-1 outage.
Posted Oct 21, 2025 - 08:28 AEDT
This incident affected: Eugene Services (Genie, Orko, Webhooks) and Eugene Member Portal, Eugene Partner Portal.